Mikrotik : DHCP dan Internet Gateway Server

Keterangan : Artikel ini ditulis oleh Guest Blogger pada Blog Migrasi Windows-Linux, Ahriyan Ibrahim. Ahriyan Ibrahim bekerja pada PT. Pasifik Satelit Nusantara (PSN).


mikrotikDi artikel sebelumnya saya telah menjelaskan cara instalasi mikrotik, selanjutnya saya akan mencoba menjelaskan cara-cara membuat Mikrotik menjadi DHCP dan Gateway Server. DHCP sangat bermanfaat bagi seorang network admin untuk mengelola jaringan komputernya karena ip address bagi client akan diberikan secara otomatis, sedangkan Internet Gateway Server bermanfaat untuk memberikan akses internet ke masing-masing user yang ada pada jaringan.


Untuk membuat DHCP Server diperlukan langkah-langkah sebagai berikut :

1. Membuat address pool dan menentukan IP Range
2. Mengaktifkan DHCP server.

Sedangkan untuk membuat Internet Gateway Server, inti langkahnya adalah melakukan masquerading yang akan melewatkan paket-paket data ke user.

Berikut ini adalah gambaran dari network dan servernya :

1. Mikrotik di install pada CPU dengan 2 ethernet card, 1 interface utk koneksi ke internet, 1 interface utk konek ke lokal.

2.  IP address :
    – gateway (mis: ADSL modem)     : 192.168.100.100
    – DNS             : 192.168.100.110
    – interface utk internet : 192.168.100.1
    – interface utk lokal     : 192.168.0.1      

Untuk memulainya, kita lihat interface yang ada pada Mikrotik Router

[admin@Mikrotik] > interface print
Flags: X – disabled, D – dynamic, R – running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R ether2 ether 0 0 1500
[admin@Mikrotik] >

kemudian set IP address pada interface Mikrotik. Misalkan ether1 akan kita gunakan untuk koneksi ke Internet dengan IP 192.168.100.1 dan ether2 akan kita gunakan untuk network local kita dengan IP 192.168.0.1

[admin@mikrotik] > ip address add address=192.168.100.1 netmask=255.255.255.0 interface=ether1

[admin@mikrotik] > ip address add address=192.168.0.1 netmask=255.255.255.0 interface=ether2

[admin@mikrotik] >ip address print
Flags: X – disabled, I – invalid, D – dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 192.168.100.1/24 192.168.100.0 192.168.100.255 ether1
1 192.168.0.1/24 192.168.0.0 192.168.0.255 ether2
[admin@mikrotik] >

Setelah selesai Barulah kita bisa melakukan setup DHCP server pada Mikrotik.

1. Membuat address pool

/ip pool add name=dhcp-pool ranges=192.168.0.2-192.168.0.100
/ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1

2. Tentukan interface yang dipergunakan dan aktifkan DHCP Server.

/ip dhcp-server add interface=ether2 address-pool=dhcp-pool enable 0

[admin@mikrotik] > ip dhcp-server print
Flags: X – disabled, I – invalid
# NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP
0  dhcp1 ether2

sampai tahap ini, DHCP server telah selesai untuk dipergunakan dan sudah bisa di test dari user.

Langkah Selanjutnya adalah membuat internet gateway, Misalnya IP ADSL Modem sebagai gateway untuk koneksi internet adalah 192.168.100.100 dan DNS Servernya 192.168.100.110, maka lakukan setting default gateway dengan perintah berikut :

[admin@mikrotik] > /ip route add gateway=192.168.100.100

3. Melihat Tabel routing pada Mikrotik Routers

[admin@mikrotik] > ip route print

Flags: X – disabled, A – active, D – dynamic,
C – connect, S – static, r – rip, b – bgp, o – ospf
# DST-ADDRESS PREFSRC G GATEWAY DISTANCE INTERFACE
0 ADC 192.168.0.0/24 192.168.0.1 ether2
1 ADC 192.168.100.0/24 192.168.100.1 ether1
2 A S 0.0.0.0/0 r 192.168.100.100 ether1
[admin@mikrotik] >

Lanjutkan dengan Setup DNS

[admin@mikrotik] > ip dns set primary-dns=192.168.100.110 allow-remoterequests=no

[admin@mikrotik] > ip dns print
primary-dns: 192.168.100.110
secondary-dns: 0.0.0.0
allow-remote-requests: no
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 16KiB

[admin@mikrotik] >

4. Tes untuk akses domain, misalnya dengan ping nama domain

[admin@mikrotik] > ping yahoo.com

216.109.112.135 64 byte ping: ttl=48 time=250 ms
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 571/571.0/571 ms

[admin@mikrotik] >

Jika sudah berhasil reply berarti seting DNS sudah benar.

5. Setup Masquerading, ini adalah langkah utama untuk menjadikan Mikrotik sebagai gateway server

[admin@mikrotik] > ip firewall nat add action=masquerade outinterface=ether1chain: srcnat

[admin@mikrotik] >

[admin@mikrotik] ip firewall nat print
Flags: X – disabled, I – invalid, D – dynamic
0 chain=srcnat out-interface=ether1 action=masquerade
[admin@mikrotik] >

Selesai, tinggal test koneksi dari user. seharusnya dengan cara ini user sudah  bisa terhubung ke internet.

Cara ini memang cara yang paling mudah untuk membuat user dapat terhubung ke internet, namun tingkat keamanannya masih rendah dan diperlukan pengaturan firewall. Mudah-mudahan saya bisa membahasnya dilain waktu.

Pin It

4 thoughts on “Mikrotik : DHCP dan Internet Gateway Server

  1. setelah sampai pada step set dns di mikrotik, sewaktu ping ke yahoo ga mau connect? utk ip publik aku pake 192.168.1.1 ip lokal 192.168.10.1 dns 202.134.0.155 scnd 202.134.1.10 ping kemasing ether ga ada masalah tapi ke domain ga mau gimana nih mas help me plz …………..

  2. Mas adri, itu kemungkinan karena dns nya dis et no di allow-remote-request..

    Atau mungkin mas vavai ini puny alasan lain untuk set allow-remote-request mnejaid no? Mohon pencerahan nya kang..

Leave a Reply

Your email address will not be published. Required fields are marked *


*